【Python】YAML版本导致的读取错误LoadWarning: calling yaml.load() without Loader=... is deprecated

原因是新版本yaml弃用了原版本的用法。
解决方案一:使用低版本yaml。

pip install pyyaml=3.12

解决方案二:使用全模式加载

yaml.load(list, Loader=yaml.FullLoader)

在这里插入图片描述

©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页